diff setup.py @ 0:4ff2aee11e5b

planemo upload
author jpayne
date Tue, 06 Nov 2018 09:45:57 -0500
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Nov 06 09:45:57 2018 -0500
@@ -0,0 +1,19 @@
+
+from setuptools import setup
+
+setup(
+    name = "seqsero2",
+    version = "2.0",
+    author = "DengLab",
+    author_email = "seqsero@gmail.com",
+    description = ("Serotyping for Salmonella."),
+    license = "GPL-2.0",
+    keywords = "salmonella",
+    url = "https://github.com/charesredhat/SeqSero2",
+    packages=['seqsero2'],
+    scripts=['scripts/SeqSero2.py'],
+     entry_points={
+        'console_scripts': ['SeqSero2 = seqsero2.SeqSero2:main']
+    },
+    package_dir = {'seqsero2': 'scripts'}
+)