diff SeqSero2/setup.py @ 4:b82e5f3c9187

planemo upload
author jpayne
date Thu, 18 Apr 2019 15:18:14 -0400
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SeqSero2/setup.py	Thu Apr 18 15:18:14 2019 -0400
@@ -0,0 +1,19 @@
+
+from distutils.core import setup
+
+setup(
+    name = "seqsero2",
+    version = "2.0",
+    author = "DengLab",
+    author_email = "seqsero@gmail.com",
+    description = ("Serotyping for Salmonella."),
+    license = "GPL-2.0",
+    keywords = "salmonella",
+    url = "https://github.com/CFSAN-Biostatistics/SeqSero2",
+    packages=['seqsero2'],
+    scripts=['scripts/SeqSero2.py'],
+     entry_points={
+        'console_scripts': ['SeqSero2 = seqsero2.SeqSero2:main']
+    },
+    package_dir = {'seqsero': 'scripts'}
+)