diff CSP2/CSP2_env/env-d9b9114564458d9d-741b3de822f2aaca6c6caa4325c4afce/lib/python3.8/site-packages/bio-1.6.2.dist-info/METADATA @ 69:33d812a61356

planemo upload commit 2e9511a184a1ca667c7be0c6321a36dc4e3d116d
author jpayne
date Tue, 18 Mar 2025 17:55:14 -0400
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/CSP2/CSP2_env/env-d9b9114564458d9d-741b3de822f2aaca6c6caa4325c4afce/lib/python3.8/site-packages/bio-1.6.2.dist-info/METADATA	Tue Mar 18 17:55:14 2025 -0400
@@ -0,0 +1,147 @@
+Metadata-Version: 2.1
+Name: bio
+Version: 1.6.2
+Summary: bio
+Home-page: https://github.com/ialbert/bio
+Author: Istvan Albert
+Author-email: istvan.albert@gmail.com
+Classifier: Programming Language :: Python :: 3
+Classifier: License :: OSI Approved :: MIT License
+Classifier: Operating System :: OS Independent
+Requires-Python: >=3.7
+Description-Content-Type: text/markdown
+License-File: LICENSE
+Requires-Dist: biopython >=1.80
+Requires-Dist: requests
+Requires-Dist: tqdm
+Requires-Dist: mygene
+Requires-Dist: pandas
+Requires-Dist: pooch
+Requires-Dist: gprofiler-official
+
+# bio: making bioinformatics fun again
+
+`bio` - command-line utilities to make bioinformatics explorations more enjoyable.
+
+`bio` is a bioinformatics toy to play with.
+
+Like LEGO pieces that match one another `bio` aims to provide you with commands that naturally fit together and let you express your intent with short, explicit and simple commands. It is a project in an exploratory phase, we'd welcome input and suggestions on what it should grow up into.
+
+## What does this software do?
+
+
+If you've ever done bioinformatics, you know how even seemingly straightforward tasks require multiple steps, arcane incantations, and various other preparations that slow down progress. 
+
+Even well-defined, supposedly simple tasks can take a seemingly inordinate number of complicated steps. The `bio` package is meant to solve that tedium. 
+
+## Usage examples
+
+    # Fetch genbank data
+    bio fetch NC_045512 MN996532 > genomes.gb
+
+    # Convert the first then bases of the genomes to FASTA.
+    bio fasta genomes.gb --end 10
+
+    # Align the coding sequences for the S protein
+    bio fasta genomes.gb --gene S --protein | bio align | head
+
+    # Print the GFF record that corresponds to the coding sequence for gene S
+    bio gff genomes.gb --gene S 
+
+    # Show the descendants of taxid 117565
+    bio taxon 117565 | head
+
+    # Show the lineage of a taxonomic rank.
+    bio taxon 117565 --lineage | head
+
+    # Get metadata on a viral sample
+    bio meta 11138 -H | head
+
+    # Define a sequence ontology terms
+    bio define exon
+
+    # Define a gene ontology terms
+    bio define food vacuole
+
+## Documentation
+
+Detailed documentation is maintained at
+
+* https://www.bioinfo.help/
+
+## Quick install
+    
+`bio` works on Linux and Mac computers and on Windows when using the Linux Subsystem. 
+
+    pip install bio --upgrade
+            
+See more details in the [documentation][docs].
+
+## `bio` is stream oriented
+
+`bio` supports stream oriented programming where the output of one task may be chained into the second. Take the example above
+but now start with a file `acc.txt` that contains just the accession numbers:
+
+    NC_045512
+    MN996532
+
+we can run `bio` to generate a VCF file with the variants of the S nucleotides forming the S protein like so:
+
+    cat acc.txt | bio fetch | bio fasta --gene S | bio align --vcf | head
+
+to print:
+
+    ##fileformat=VCFv4.2
+    ##FORMAT=<ID=GT,Number=1,Type=String,Description="Genotype">
+    ##FILTER=<ID=PASS,Description="All filters passed">
+    ##INFO=<ID=TYPE,Number=1,Type=String,Description="Type of the variant">
+    ##contig=<ID=YP_009724390.1,length=3822,assembly=YP_009724390.1>
+    #CHROM  POS     ID      REF     ALT     QUAL    FILTER  INFO    FORMAT  QHR63300.2
+    YP_009724390.1  33      33C/T   C       T       .       PASS    TYPE=SNP        GT      1
+    YP_009724390.1  54      54T/A   T       A       .       PASS    TYPE=SNP        GT      1
+    YP_009724390.1  60      60C/T   C       T       .       PASS    TYPE=SNP        GT      1
+    YP_009724390.1  69      69A/G   A       G       .       PASS    TYPE=SNP        GT      1
+
+
+## Who is `bio` designed for?
+
+The software was written to teach bioinformatics and is the companion software to the [Biostar Handbook][handbook] textbook. The targeted audience comprises:
+
+- Students learning about bioinformatics.
+- Bioinformatics educators who need a platform to demonstrate bioinformatics concepts. 
+- Scientists working with large numbers of similar genomes (bacterial/viral strains).
+- Scientists who need to investigate and understand the precise details of a genomic region closely.
+
+The ideas and motivations fueling `bio` have been developed while educating the many cohorts of students who used the handbook in the classroom. `bio` is an opinionated take on how bioinformatics, particularly data representation and access, should be simplified and streamlined.
+
+[handbook]: https://www.biostarhandbook.com/
+[docs]: https://www.bioinfo.help/
+
+## Development
+
+If you clone the repository, we recommend that you install it as a development package with:
+
+    python setup.py develop
+    
+## Testing
+
+`bio` can test itself, to run all tests execute:
+
+    bio test
+
+Tests are automatically built from a shell script that mimics real-life usage scenarios.
+
+* https://github.com/ialbert/bio/blob/master/test/usage.sh
+
+## Generating documentation
+
+To generate the docs, you will need the `bookdown` package:
+
+    conda install r-bookdown r-servr
+    
+To run the docs in a browse:
+    
+    make 
+    
+then visit http://localhost:8000
+